How to see the PIs?

So, I have successfully (I think) flashed the Raspian O/S onto each of the 2 SD cards.
Note to self: Buy an SD card with it pre-installed next time!

Initially, just one of the PIs changed from a red to a green light. I assume the O/S hasn’t been successfully written onto the one with the red light (but how to tell?).

Even though all devices (excl the Dell which isn’t turned on) are connected into the network switch device (TP-link). The light for port(2) on the switch is out. Probably echoes the above.

I swapped the SD cards between the 2 PIs and now have 4 lights on the switch. And all the PIs are green. Odd.

So, looks like we have a cluster and the O/S flashing onto each card has been successful. An afternoon of my life i’d rather not have to repeat!

Successfully flashed the O/S onto the PIs

I do like green lights!

What next?!

So, I run Puppet and hope(!) it can see the ‘members’ or ‘nodes’. TBH, I don’t know how to use Puppet (yet).

But, it only sees the laptop :(

Doh! Was hoping Puppet could see everything connected into the network switch (laptop & 3 RPi)

I know I have to do some O/S stuff now

But cannot ‘see’  each PI. Maybe I need to buy a video cable and connect them to a monitor, but had hoped I could switch to them from the laptop? One for tomorrow!

Update: Until you have successfully got SSH enabled and figured out the IP [ip show addr] address for each raspberry Pi, i’d recommend a HDMI switch, which lets you easily toggle between devices, without having to plug/unplug HDMI cables from your monitor

Let’s you flip between 3 devices. I have laptop in HDMI port 1 and the 3 R Pis into the switch and into HDMI port 2